Sunday, July 23, 2017

The "@angular/compiler-cli" package was not properly installed.

The "@angular/compiler-cli" package was not properly installed.

https://github.com/angular/angular-cli/issues/5654
Easiest way to debug any CLI error is to just generate a new project and compare files like your package.json: ng new temporary


Setting up an Angular working app is still so tedious. I think this should be addressed by core team. If the team is creating an awesome product, then it should be awesome to use it too. Fixing Angular setup problems are like finding a pearl in shell. 
https://github.com/angular/angular-cli/issues/5654

My fix:

delete node_modules
npm cache clean --force
npm install

Up and running! P.s: Moving @angular/cli to dependencies is wrong, it belongs to devDependencies
https://github.com/angular/angular-cli/issues/5654

My fix was to set production to false and after that local npm install
sudo npm config set -g production false

npm install

npm start errors

i dont think angular has much hope . with so many errors how secure is angular?

https://angular.io/tutorial/toh-pt1

npm start

 Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

There are TOO many dependencies in angular which keeps breaking. 


We updated all our dependencies and now using minimatch ^3.0.2 (look at this F**. no solution just closes the thread. This is why thse guys are such f***)

https://github.com/babel/babel/issues/4360

npm install minimatch@3.0.2 --save-dev
https://github.com/npm/npm/issues/13525
npm notice created a lockfile as package-lock.json. You should commit this file.
+ minimatch@3.0.2

npm ERR! code EINTEGRITY
npm ERR! sha1-QMfm6eXaeWG3cYtVUF+crJSHpgc= integrity checksum failed when using sha1: wanted sha1-QMfm6eXaeWG3cYtVUF+crJSHpgc= but got sha1-NuI7Ftb+5IxA4rGI4YOOi4RcqJc=. (32240 bytes)

Thursday, July 20, 2017

ng new my-app

ng new my-app
Directory /home/user/my-app exists and is already an Angular CLI project.

https://github.com/angular/angular-cli/issues/1079

https://github.com/angular/angular-cli/pull/4901


Use the below command :

rm -rf lampp
It deletes all files and folders contained in the lampp directory.

In case user doesn't have the permission to delete the folder:

Add sudo at the beginning of the command :

sudo rm -rf folderName
https://askubuntu.com/questions/217893/how-to-delete-a-non-empty-directory-in-terminal


ng new my-app
path.js:1163
          cwd = process.cwd();
                        ^

Error: ENOENT: no such file or directory, uv_cwd
    at Object.resolve (path.js:1163:25)
    at Function.Module._resolveLookupPaths (module.js:408:17)
    at Function.Module._resolveFilename (module.js:480:22)
    at Function.Module._load (module.js:437:25)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at Object. (/usr/local/lib/node_modules/@angular/cli/bin/ng:7:19)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)


https://github.com/npm/npm/issues/10983
That happened with me when I removed the directory on one terminal, but was in it on another. Just cd out of it and then back helped.
https://github.com/npm/npm/issues/10983
EACCES: permission denied, mkdir '/my-app'

Error: EACCES: permission denied, mkdir '/my-app'


probably combined with running npm cache clean to get any busted packages out of your cache.
https://github.com/npm/npm/issues/5869
https://github.com/zeit/now-cli/issues/378

npm WARN saveError EACCES: permission denied, open '/package-lock.json.577729328'
package-lock.json is automatically generated for any operations where npm modifies either the node_modules tree, or package.json

Conceptually, the "input" to npm-install is a package.json, while its "output" is a fully-formed node_moduleshttps://docs.npmjs.com/files/package-locks

npm WARN saveError ENOENT: no such file or directory, open '/package.json'

sudo npm install npm@latest -g


  • Create a package.json file and store it in the folder where you will install the npm package. Keep it simple for now. This npm video helped me. Also read Using a package.json for additional information. The following example satisfies the minimum requirements:
    {
    "name": "demo-app",
    "version": "1.0.0"
    }

rm -rf /usr/local/lib/node_modules
brew uninstall node
brew install node --without-npm
echo prefix=~/.npm-packages >> ~/.npmrc
curl -L https://www.npmjs.com/install.sh | sh

we are moving the CLI npm with the next release,

 ng new my-app
As a forewarning, we are moving the CLI npm package to "@angular/cli" with the next release,
which will only support Node 6.9 and greater. This package will be officially deprecated
shortly after.

To disable this warning use "ng set --global warnings.packageDeprecation=false".


git hub is full of shitty queries. because the developers just dont know their stuff?wtf is happening?

https://github.com/angular/angular-cli/issues/4368


https://github.com/angular/angular-cli/issues/5558

The project needs a dev dependency for @angular/compiler-cli.
npm install --save-dev @angular/compiler-cli@
https://github.com/angular/angular-cli/issues/5558

https://github.com/angular/angular-cli/issues/4368#issuecomment-277152176


I'm sorry that this release wrecked havoc in older releases, and that it has caused you to have to spend time updating and fixing packages.

This isn't something that you can expect to be fixed without an update on your side though. I'm sorry but it's just not. beta.18 and beta.28.3 are versions that were never meant to be supported long term and we never tried to hide that. The only version for which there is long term support is 1.0 when it is out.


Here is the angular-cli Git Page details:

If you're using Angular CLI beta.28 or less, you need to uninstall angular-cli package. It should be done due to changing of package's name and scope from angular-cli to @angular/cli:
npm uninstall -g angular-cli
npm uninstall --save-dev angular-cli
To update Angular CLI to a new version, you must update both the global package and your project's local package.
Global package:
npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli@latest
Local project package:
rm -rf node_modules dist # use rmdir /S/Q node_modules dist in Windows Command Prompt; use rm -r -fo node_modules,dist in Windows PowerShell
npm install --save-dev @angular/cli@latest
npm install


I think you shoud update to angualr cli 1.0 :
npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli@latest
remove local project package:rm -rf node_modules dist # use rmdir on Windows
then install angular cli locally in your repo : npm install --save-dev @angular/cli@latest
finally : npm install
you should read over this for further infos: stories 1.0 update
https://github.com/angular/angular-cli/issues/5558


Angular CLI can now be found on NPM under @angular/cli instead of angular-cli, and has a minimum requirement of Node 6.9.0 or higher, together with NPM 3 or higher.
If you're using Angular CLI beta.28 or less, you need to uninstall the angular-cli package.
npm uninstall -g angular-cli
npm uninstall --save-dev angular-cli
To update Angular CLI to a new version, you must update both the global package and your project's local package.
Global package:
npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli@latest
Local project package:


rm -rf node_modules dist # use rmdir on Windows
npm install --save-dev @angular/cli@latest
npm install
F*** another error

npm cache clean
npm ERR! As of npm@5, the npm cache self-heals from corruption issues and data extracted from the cache is guaranteed to be valid. If you want to make sure everything is consistent, use 'npm cache verify' instead.
npm ERR!
npm ERR! If you're sure you want to delete the entire cache, rerun this command with --force.

npm ERR! A complete log of this run can be found in:

npm cache -f clean
npm WARN using --force I sure hope you know what you are doing.


+ @angular/cli@1.2.1
added 743 packages and updated 2 packages in 140.53s


linux mint 18.2 error

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules/@angular/cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Those warnings are OK.

You should not and cannot do anything with them.  << wtf!
Note OPTIONAL DEPENDENCY, which means it is not strict.
https://github.com/angular/angular-cli/issues/6467


another shitty angular install error

 user "root" does not have permission to access the dev dir "/usr/local/lib/node_modules/@angul


google top link
https://github.com/angular/angular-cli/issues/2161

npm uninstall -g angular-cli
npm install -g -f angular-cli


npm install -g -f angular-cli


stack: 'Error: EACCES: permission denied, mkdir \'/usr/local/lib/node_modules/.staging\'',

TypeError: Cannot read property 'write' of null
    at Zlib.callback (zlib.js:469:32)


https://docs.npmjs.com/getting-started/fixing-npm-permissions
npm config get prefix
/usr/local


 sudo chown -R $(whoami) $(npm config get prefix)/{lib/node_modules,bin,share}



┌──────────────────────────────────────────────────────────────┐
│                   npm update check failed                    │
│             Try running with sudo or get access              │
│             to the local update config store via             │
│ sudo chown -R $USER:$(id -gn $USER) /home/your user name /.config │
└────────────────────────────────────────────

https://askubuntu.com/questions/925545/npm-update-check-failed

upgrading npm

so trying https://davidwalsh.name/nvm

nvm ls
No command 'nvm' found, did you mean:
 Command 'n-m' from package 'python-networkmanager' (universe)
 Command 'kvm' from package 'qemu-kvm' (main)
 Command 'nvme' from package 'nvme-cli' (universe)
 Command 'pvm' from package 'pvm' (universe)
 Command 'nvi' from package 'nvi' (universe)
 Command 'vm' from package 'mgetty-voice' (universe)
 Command 'nam' from package 'nam' (universe)
 Command 'npm' from package 'npm' (universe)
 Command 'nim' from package 'nim' (universe)
 Command 'nm' from package 'binutils' (main)
 Command 'nm' from package 'binutils-multiarch' (main)
 Command 'lvm' from package 'lvm2' (main)
nvm: command not found

how to upgrade nodejs
google top link https://tecadmin.net/upgrade-nodejs-via-npm/ good link thanks google and thanks rahul

sudo npm cache clean -f
[sudo] password for :
npm WARN using --force I sure hope you know what you are doing.
sudo npm install -g n
/usr/local/bin/n -> /usr/local/lib/node_modules/n/bin/n
/usr/local/lib
└── n@2.1.8
 sudo n stable

     install : node-v8.2.0
       mkdir : /usr/local/n/versions/node/8.2.0
       fetch : https://nodejs.org/dist/v8.2.0/node-v8.2.0-linux-x64.tar.gz
   installed : v8.2.0
admin:~$ sudo ln -sf /usr/local/n/versions/node/8.2.0/bin/node /usr/bin/node

 node -v
v8.2.0


angular cli fail end skipped the rest

32955 silly generateActionsToTake Starting
32956 silly install generateActionsToTake
32957 warn checkPermissions Missing write access to /usr/local/lib
32958 silly rollbackFailedOptional Starting
32959 silly rollbackFailedOptional Finishing
32960 silly runTopLevelLifecycles Starting
32961 silly runTopLevelLifecycles Finishing
32962 silly install printInstalled
32963 warn optional Skipping failed optional dependency /@angular/cli/chokidar/fsevents:
32964 warn notsup Not compatible with your operating system or architecture: fsevents@1.1.2
32965 verbose stack Error: EACCES: permission denied, access '/usr/local/lib'
32965 verbose stack     at Error (native)
32966 verbose cwd /home/user
32967 error Linux 4.8.0-58-generic
32968 error argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "@angular/cli"
32969 error node v4.2.6
32970 error npm  v3.5.2
32971 error path /usr/local/lib
32972 error code EACCES
32973 error errno -13
32974 error syscall access
32975 error Error: EACCES: permission denied, access '/usr/local/lib'
32975 error     at Error (native)
32975 error  { [Error: EACCES: permission denied, access '/usr/local/lib']
32975 error   errno: -13,
32975 error   code: 'EACCES',
32975 error   syscall: 'access',
32975 error   path: '/usr/local/lib' }
32976 error Please try running this command again as root/Administrator.
32977 verbose exit [ -13, true ]

maybe?
npm install -g @angular/cli should have been sudo npm install -g @angular/cli ?

WARN engine @angular/cli@1.2.1: wanted: {"node":">= 6.9.0","npm":">= 3.0.0"} (current: {"node":"4.2.6","npm":"3.5.2"})
https://github.com/angular/angular-cli/issues/6140
Looks like you've got node v4.2.6 installed. AngularCLI requires >= 6.9.0. Go to https://nodejs.org/en/ and download the latest version.

but F**** linux shitty mint installed that old version !!


A simple way to upgrade Node.js from the Terminal is to use the n version manager:
  1. 1 npm install -g n 2 npm cache clean -f.
  2. 1 cd /Applications/XAMPP/xamppfiles/bin 2 sudo mv HEAD _HEAD.
  3. 1 sudo n stable 2 npm update -g.
  4. 1 cd /Applications/XAMPP/xamppfiles/bin 2 sudo mv _HEAD HEAD.
  5. 1 node -v 2 npm -v

this is what google gives me as an answer. I dont F** have xampp

https://davidwalsh.name/nvm

npm WARN optional Skipping failed optional dependency /@angular/cli/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2

google show this link as top solution. cant understand shit on this link
https://github.com/LLK/scratch-blocks/issues/674



angular cli fail p2

22035 silly get     via: '1.1 varnish',
22035 silly get     age: '176',
22035 silly get     connection: 'keep-alive',
22035 silly get     'x-served-by': 'cache-lcy1128-LCY',
22035 silly get     'x-cache': 'HIT',
22035 silly get     'x-cache-hits': '2',
22035 silly get     'x-timer': 'S1500558830.342088,VS0,VE0',
22035 silly get     vary: 'Accept-Encoding, Accept' } ]
22036 verbose get saving wordwrap to /home/user/.npm/registry.npmjs.org/wordwrap/.cache.json
22037 silly resolveWithNewModule wordwrap@0.0.3 checking installable status
22038 silly cache add args [ 'wordwrap@~0.0.2', null ]
22039 verbose cache add spec wordwrap@~0.0.2
22040 silly cache add parsed spec Result {
22040 silly cache add   raw: 'wordwrap@~0.0.2',
22040 silly cache add   scope: null,
22040 silly cache add   name: 'wordwrap',
22040 silly cache add   rawSpec: '~0.0.2',
22040 silly cache add   spec: '>=0.0.2 <0 .1.0="" p="">22040 silly cache add   type: 'range' }
22041 silly addNamed wordwrap@>=0.0.2 <0 .1.0="" p="">22042 verbose addNamed ">=0.0.2 <0 .1.0="" a="" for="" is="" p="" range="" semver="" valid="" wordwrap="">22043 silly addNameRange { name: 'wordwrap', range: '>=0.0.2 <0 .1.0="" false="" hasdata:="" p="">22044 silly mapToRegistry name wordwrap
22045 silly mapToRegistry using default registry
22046 silly mapToRegistry registry https://registry.npmjs.org/
22047 silly mapToRegistry uri https://registry.npmjs.org/wordwrap
22048 verbose addNameRange registry:https://registry.npmjs.org/wordwrap not in flight; fetching
22049 verbose get https://registry.npmjs.org/wordwrap not expired, no request
22050 silly addNameRange number 2 { name: 'wordwrap', range: '>=0.0.2 <0 .1.0="" hasdata:="" p="" true="">22051 silly addNameRange versions [ 'wordwrap', [ '0.0.1', '0.0.2', '0.0.3', '1.0.0' ] ]
22052 silly addNamed wordwrap@0.0.3
22053 verbose addNamed "0.0.3" is a plain semver version for wordwrap
22054 silly mapToRegistry name wordwrap
22055 silly mapToRegistry using default registry
22056 silly mapToRegistry registry https://registry.npmjs.org/
22057 silly mapToRegistry uri https://registry.npmjs.org/wordwrap
22058 verbose addRemoteTarball https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz not in flight; adding
22059 verbose addRemoteTarball [ 'https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz',
22059 verbose addRemoteTarball   'a3d5da6cd5c0bc0008d37234bbaf1bed63059107' ]
22060 info retry fetch attempt 1 at 7:23:50 PM
22061 info attempt registry request try #1 at 7:23:50 PM
22062 http fetch GET https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz
22063 http fetch 200 https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz
22064 silly fetchAndShaCheck shasum a3d5da6cd5c0bc0008d37234bbaf1bed63059107
22065 verbose addTmpTarball /tmp/npm-7075-fa89e4f7/registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz not in flight; adding
22066 verbose addTmpTarball already have metadata; skipping unpack for wordwrap@0.0.3
22067 silly cache afterAdd wordwrap@0.0.3
22068 verbose afterAdd /home/user/.npm/wordwrap/0.0.3/package/package.json not in flight; writing
22069 verbose afterAdd /home/user/.npm/wordwrap/0.0.3/package/package.json written
22070 silly fetchNamedPackageData async
22071 silly mapToRegistry name async
22072 silly mapToRegistry using default registry
22073 silly mapToRegistry registry https://registry.npmjs.org/
22074 silly mapToRegistry uri https://registry.npmjs.org/async
22075 silly resolveWithNewModule async@0.2.10 checking installable status
22076 silly cache add args [ 'async@~0.2.6', null ]
22077 verbose cache add spec async@~0.2.6
22078 silly fetchNamedPackageData source-map
22079 silly mapToRegistry name source-map
22080 silly mapToRegistry using default registry
22081 silly mapToRegistry registry https://registry.npmjs.org/
22082 silly mapToRegistry uri https://registry.npmjs.org/source-map
22083 silly resolveWithNewModule source-map@0.1.43 checking installable status
22084 silly cache add args [ 'source-map@~0.1.7', null ]
22085 verbose cache add spec source-map@~0.1.7
22086 silly cache add parsed spec Result {
22086 silly cache add   raw: 'async@~0.2.6',
22086 silly cache add   scope: null,
22086 silly cache add   name: 'async',
22086 silly cache add   rawSpec: '~0.2.6',
22086 silly cache add   spec: '>=0.2.6 <0 .3.0="" p="">22086 silly cache add   type: 'range' }
22087 silly addNamed async@>=0.2.6 <0 .3.0="" p="">22088 verbose addNamed ">=0.2.6 <0 .3.0="" a="" async="" for="" is="" p="" range="" semver="" valid="">22089 silly addNameRange { name: 'async', range: '>=0.2.6 <0 .3.0="" false="" hasdata:="" p="">22090 silly mapToRegistry name async
22091 silly mapToRegistry using default registry
22092 silly mapToRegistry registry https://registry.npmjs.org/
22093 silly mapToRegistry uri https://registry.npmjs.org/async
22094 verbose addNameRange registry:https://registry.npmjs.org/async not in flight; fetching
22095 silly cache add parsed spec Result {
22095 silly cache add   raw: 'source-map@~0.1.7',
22095 silly cache add   scope: null,
22095 silly cache add   name: 'source-map',
22095 silly cache add   rawSpec: '~0.1.7',
22095 silly cache add   spec: '>=0.1.7 <0 .2.0="" p="">22095 silly cache add   type: 'range' }
22096 silly addNamed source-map@>=0.1.7 <0 .2.0="" p="">22097 verbose addNamed ">=0.1.7 <0 .2.0="" a="" for="" is="" p="" range="" semver="" source-map="" valid="">22098 silly addNameRange { name: 'source-map', range: '>=0.1.7 <0 .2.0="" false="" hasdata:="" p="">22099 silly mapToRegistry name source-map
22100 silly mapToRegistry using default registry
22101 silly mapToRegistry registry https://registry.npmjs.org/
22102 silly mapToRegistry uri https://registry.npmjs.org/source-map
22103 verbose addNameRange registry:https://registry.npmjs.org/source-map not in flight; fetching
22104 verbose request uri https://registry.npmjs.org/async
22105 verbose request no auth needed
22106 info attempt registry request try #1 at 7:23:51 PM
22107 verbose etag W/"596f3877-21bc5"
22108 verbose lastModified Wed, 19 Jul 2017 10:46:15 GMT
22109 http request GET https://registry.npmjs.org/async
22110 verbose request uri https://registry.npmjs.org/source-map
22111 verbose request no auth needed
22112 info attempt registry request try #1 at 7:23:51 PM
22113 verbose etag W/"596cf94b-252b1"
22114 verbose lastModified Mon, 17 Jul 2017 17:52:11 GMT
22115 http request GET https://registry.npmjs.org/source-map
22116 http 304 https://registry.npmjs.org/source-map
22117 verbose headers { date: 'Thu, 20 Jul 2017 13:53:51 GMT',
22117 verbose headers   via: '1.1 varnish',
22117 verbose headers   'cache-control': 'max-age=300',
22117 verbose headers   etag: 'W/"596cf94b-252b1"',
22117 verbose headers   age: '80',
22117 verbose headers   connection: 'keep-alive',
22117 verbose headers   'x-served-by': 'cache-lcy1130-LCY',
22117 verbose headers   'x-cache': 'HIT',
22117 verbose headers   'x-cache-hits': '5',
22117 verbose headers   'x-timer': 'S1500558831.420198,VS0,VE0',
22117 verbose headers   vary: 'Accept-Encoding, Accept' }
22118 silly get cb [ 304,
22118 silly get   { date: 'Thu, 20 Jul 2017 13:53:51 GMT',
22118 silly get     via: '1.1 varnish',
22118 silly get     'cache-control': 'max-age=300',
22118 silly get     etag: 'W/"596cf94b-252b1"',
22118 silly get     age: '80',
22118 silly get     connection: 'keep-alive',
22118 silly get     'x-served-by': 'cache-lcy1130-LCY',
22118 silly get     'x-cache': 'HIT',
22118 silly get     'x-cache-hits': '5',
22118 silly get     'x-timer': 'S1500558831.420198,VS0,VE0',
22118 silly get     vary: 'Accept-Encoding, Accept' } ]
22119 verbose etag https://registry.npmjs.org/source-map from cache
22120 verbose get saving source-map to /home/user/.npm/registry.npmjs.org/source-map/.cache.json
22121 http 304 https://registry.npmjs.org/async
22122 verbose headers { date: 'Thu, 20 Jul 2017 13:53:51 GMT',
22122 verbose headers   via: '1.1 varnish',
22122 verbose headers   'cache-control': 'max-age=300',
22122 verbose headers   etag: 'W/"596f3877-21bc5"',
22122 verbose headers   age: '148',
22122 verbose headers   connection: 'keep-alive',
22122 verbose headers   'x-served-by': 'cache-lcy1145-LCY',
22122 verbose headers   'x-cache': 'HIT',
22122 verbose headers   'x-cache-hits': '6',
22122 verbose headers   'x-timer': 'S1500558831.431946,VS0,VE0',
22122 verbose headers   vary: 'Accept-Encoding, Accept' }
22123 silly get cb [ 304,
22123 silly get   { date: 'Thu, 20 Jul 2017 13:53:51 GMT',
22123 silly get     via: '1.1 varnish',
22123 silly get     'cache-control': 'max-age=300',
22123 silly get     etag: 'W/"596f3877-21bc5"',
22123 silly get     age: '148',
22123 silly get     connection: 'keep-alive',
22123 silly get     'x-served-by': 'cache-lcy1145-LCY',
22123 silly get     'x-cache': 'HIT',
22123 silly get     'x-cache-hits': '6',
22123 silly get     'x-timer': 'S1500558831.431946,VS0,VE0',
22123 silly get     vary: 'Accept-Encoding, Accept' } ]
22124 verbose etag https://registry.npmjs.org/async from cache
22125 verbose get saving async to /home/user/.npm/registry.npmjs.org/async/.cache.json
22126 silly addNameRange number 2 { name: 'source-map', range: '>=0.1.7 <0 .2.0="" hasdata:="" p="" true="">

angular cli fail p1

22011 http fetch 200 https://registry.npmjs.org/optimist/-/optimist-0.3.7.tgz
22012 silly fetchAndShaCheck shasum c90941ad59e4273328923074d2cf2e7cbc6ec0d9
22013 verbose addTmpTarball /tmp/npm-7075-fa89e4f7/registry.npmjs.org/optimist/-/optimist-0.3.7.tgz not in flight; adding
22014 verbose addTmpTarball already have metadata; skipping unpack for optimist@0.3.7
22015 silly cache afterAdd optimist@0.3.7
22016 verbose afterAdd /home/user/.npm/optimist/0.3.7/package/package.json not in flight; writing
22017 verbose afterAdd /home/user/.npm/optimist/0.3.7/package/package.json written
22018 silly fetchAndShaCheck shasum fa0984770b428b7a9b2a8058f46355d14fef211a
22019 verbose addTmpTarball /tmp/npm-7075-fa89e4f7/registry.npmjs.org/uglify-js/-/uglify-js-2.3.6.tgz not in flight; adding
22020 verbose addTmpTarball already have metadata; skipping unpack for uglify-js@2.3.6
22021 silly cache afterAdd uglify-js@2.3.6
22022 verbose afterAdd /home/user/.npm/uglify-js/2.3.6/package/package.json not in flight; writing
22023 verbose afterAdd /home/user/.npm/uglify-js/2.3.6/package/package.json written
22024 silly fetchNamedPackageData wordwrap
22025 silly mapToRegistry name wordwrap
22026 silly mapToRegistry using default registry
22027 silly mapToRegistry registry https://registry.npmjs.org/
22028 silly mapToRegistry uri https://registry.npmjs.org/wordwrap
22029 verbose request uri https://registry.npmjs.org/wordwrap
22030 verbose request no auth needed
22031 info attempt registry request try #1 at 7:23:50 PM
22032 http request GET https://registry.npmjs.org/wordwrap
22033 http 200 https://registry.npmjs.org/wordwrap
22034 verbose headers { server: 'nginx/1.10.1',
22034 verbose headers   'content-type': 'application/json',
22034 verbose headers   'last-modified': 'Wed, 05 Apr 2017 15:51:48 GMT',
22034 verbose headers   etag: 'W/"58e51294-1b03"',
22034 verbose headers   'content-encoding': 'gzip',
22034 verbose headers   'cache-control': 'max-age=300',
22034 verbose headers   'content-length': '1845',
22034 verbose headers   'accept-ranges': 'bytes',
22034 verbose headers   date: 'Thu, 20 Jul 2017 13:53:50 GMT',
22034 verbose headers   via: '1.1 varnish',
22034 verbose headers   age: '176',
22034 verbose headers   connection: 'keep-alive',
22034 verbose headers   'x-served-by': 'cache-lcy1128-LCY',
22034 verbose headers   'x-cache': 'HIT',
22034 verbose headers   'x-cache-hits': '2',
22034 verbose headers   'x-timer': 'S1500558830.342088,VS0,VE0',
22034 verbose headers   vary: 'Accept-Encoding, Accept' }
22035 silly get cb [ 200,
22035 silly get   { server: 'nginx/1.10.1',
22035 silly get     'content-type': 'application/json',
22035 silly get     'last-modified': 'Wed, 05 Apr 2017 15:51:48 GMT',
22035 silly get     etag: 'W/"58e51294-1b03"',
22035 silly get     'content-encoding': 'gzip',
22035 silly get     'cache-control': 'max-age=300',
22035 silly get     'content-length': '1845',
22035 silly get     'accept-ranges': 'bytes',
22035 silly get     date: 'Thu, 20 Jul 2017 13:53:50 GM

installing lightdm on linuxmint 18.2 causes a black screen at login

if you upgrade your distro to 18.2 and install lightdm and remove mdm and reboot you can get a black screen with no login option.

First, install LightDM by typing the following commands in a terminal:
apt install slick-greeter lightdm lightdm-settings apparmor
When asked to select a default display manager, select LightDM.
Then, remove MDM and reboot by typing the following commands in a terminal:
apt remove mdm
sudo reboot
i first reinstalled mdm as i could not find any solution. that helped get into the login.
but then on reboot startx kept telling me to choose between lighdm and mdm.

rebooting alt+ctrl+del and choose safe more and login into root . then
you need to run sudo dpkg-reconfigure lightdm

google search with their shitty ai was no help . how to reboot. especially for a novice linux user. 

finally tried some 2012 solution. and it worked

installing npm on linuxmint 18

$node -v
v4.2.6

$ npm -v
The program 'npm' is currently not installed. You can install it by typing:
sudo apt install npm

$ npm -v
3.5.2

installing nodejs on linuxmint 18

 ~ $ sudo apt-get install -y build-essential
[sudo] password for root:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
build-essential is already the newest version (12.1ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 ~ $ node -v
The program 'node' is currently not installed. You can install it by typing:
sudo apt install nodejs-legacy
 ~ $
 ~ $ sudo apt install nodejs-legacy
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following additional packages will be installed:
  libuv1 nodejs
The following NEW packages will be installed:
  libuv1 nodejs nodejs-legacy
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,246 kB of archives.
After this operation, 13.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libuv1 amd64 1.8.0-1 [57.4 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 nodejs amd64 4.2.6~dfsg-1ubuntu4.1 [3,161 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 nodejs-legacy all 4.2.6~dfsg-1ubuntu4.1 [27.7 kB]
Fetched 3,246 kB in 4s (691 kB/s)      
Selecting previously unselected package libuv1:amd64.
(Reading database ... 195331 files and directories currently installed.)
Preparing to unpack .../libuv1_1.8.0-1_amd64.deb ...
Unpacking libuv1:amd64 (1.8.0-1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_4.2.6~dfsg-1ubuntu4.1_amd64.deb ...
Unpacking nodejs (4.2.6~dfsg-1ubuntu4.1) ...
Selecting previously unselected package nodejs-legacy.
Preparing to unpack .../nodejs-legacy_4.2.6~dfsg-1ubuntu4.1_all.deb ...
Unpacking nodejs-legacy (4.2.6~dfsg-1ubuntu4.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for doc-base (0.10.7) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db (2.7.5-1) ...
Setting up libuv1:amd64 (1.8.0-1) ...
Setting up nodejs (4.2.6~dfsg-1ubuntu4.1) ...
update-alternatives: using /usr/bin/nodejs to provide /usr/bin/js (js) in auto mode
Setting up nodejs-legacy (4.2.6~dfsg-1ubuntu4.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...

Monday, May 8, 2017

facebook friend suggest intelligence grade deep search?

So facebook suggested a friend who was a a building engineer who i contacted once a few months ago. All logs on the phone was deleted. But this was the first time i installed and used facebook on my phone.

2nd facebook suggested a skin doctor who i saw a long time ago . BUT never contacted .

So whats the deal?

If the phone call logs are deleted who does facebook suggest this guy?

How does facebook suggest this doctor i never called but  may have googled his clinics address ?


very very curious :)

Wednesday, January 25, 2017

brute force attack from Batu Pahat, Malaysia

User IP: 58.26.113.137
User hostname: 58.26.113.137
User location: Batu Pahat, Malaysia

The Anti Hacker Alliance fights against 58.26.113.68

P Address
58.26.113.68

Hostname
ramatex.com.my

Network
Asia Pacific Network Information Centre

Country
 MY - MALAYSIA

Region
01

City
Pasir Gudang

Latitude
1.462

Longitude
103.905

IP Range
58.26.112.0 - 58.26.113.255

IP Network
American Registry for Internet Numbers (ARIN)

Monday, January 16, 2017

problems installing linux on new wd hdd

This machine's firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using "BIOS compatibility mode". If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.

If you wish to install in UEFI mode and don't care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here.

Western Digital Scorpio Blue 500 GB 5400 RPM 2.5" WD500LPCX Hard Drive HDD Sata<

https://www.wdc.com/en-um/products/internal-storage/wd-blue-mobile.html

problems installing ubutu on western digital netbook hard disks

 you keep getting  the machine firmware is installing in the UEFI mode . And then your ubuntu installation does not boot after install.

ideapad s205 does not have a disable uefi mode in the bios and you need to reflash it . most help says from windows 8 . but i DO NOT have any windows install .

so i got free dos and install it .But it just boots into free does even after installing ubuntu alongside free dos 


 sudo apt-get install p7zip-full
Reading package lists... Done
Building dependency tree      
Reading state information... Done
p7zip-full is already the newest version (9.20.1~dfsg.1-4.2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

ubuntu-mate@ubuntu-mate:~$
ubuntu-mate@ubuntu-mate:~$ sudo fdisk -l
Disk /dev/ram0: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes




Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xad971719

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1              63     96389     96327    47M  6 FAT16
/dev/sda2           98302 976771071 976672770 465.7G  5 Extended
/dev/sda5  *        98304 973412351 973314048 464.1G 83 Linux
/dev/sda6       973414400 976771071   3356672   1.6G 82 Linux swap / Solaris

Partition 1 does not start on physical sector boundary.
Partition 2 does not start on physical sector boundary.



Disk /dev/sdb: 3.7 GiB, 4004511744 bytes, 7821312 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x15651abb

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *          0 3247999 3248000  1.6G  0 Empty
/dev/sdb2       3193448 3198183    4736  2.3M ef EFI (FAT-12/16/32)


your hard disk has Advanced Format 4096-byte sectors to which the partition is not perfectly aligned. fix this issue you must backup your data and then either:
  1. Resize the erroneously sized partition to the proper size.
  2. Delete the erroneously sized partition and create a new partition of the proper size.

http://askubuntu.com/questions/156994/partition-does-not-start-on-physical-sector-boundary


The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes.


after adding 1 mb before each partition
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xad971719

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            4096     96255     92160    45M  6 FAT16
/dev/sda2           98302 976771071 976672770 465.7G  5 Extended
/dev/sda5  *       100352 973412351 973312000 464.1G 83 Linux
/dev/sda6       973414400 976771071   3356672   1.6G 82 Linux swap / Solaris

Partition 2 does not start on physical sector boundary.



Disk /dev/sdb: 3.7 GiB, 4004511744 bytes, 7821312 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x15651abb

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *          0 3247999 3248000  1.6G  0 Empty
/dev/sdb2       3193448 3198183    4736  2.3M ef EFI (FAT-12/16/32)